Data Warehouse Data not Refreshing over ODATA connection and error out Login has Timed Out
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Data Warehouse Data not Refreshing over ODATA connection and error out Login has Timed Out

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Article ID: 250273

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

Data Warehouse Data not Refreshing over ODATA connection and getting Login has Timed Out, this has happened post upgrade to 16.0.3 in GCP SaaS 

Some example with Odata Client Tools 

  • Connecting via Microsoft Power BI results in error "OLE DB or ODBC error: [DataSource.Error] OData: Request failed: The remote server returned an error: (400) Bad Request. ([HYT00][0] Login has timed out.)"

Environment

Release : 16.0.3

Component : Clarity Data Warehouse

Cause

Many reporting vendors cache the data and if the Broadcom Clarity SaaS Odata service has been restarted the connections needs to be re established again. In case of upgrade to 16.0.3 there has been upgrade to Odata version and services were restarted 

Resolution

In order to overcome this, please run the below job in the sequence and once all the jobs are successful, connecting via ODATA API should work 

  • Load Dataware house - Full mode 
  • Load Data Warehouse Access Rights
  • Refresh Data Warehouse OData Model