Universe import issue in Identity Governance, import shows 0% and never moves
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Universe import issue in Identity Governance, import shows 0% and never moves

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Article ID: 250269

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Updated On:

Products

CA Identity Manager

Issue/Introduction

All campaigns are not moving beyond "0% In Progress"

The import is showing 0% even after few hours. The following did not change the behavior:

1.Did workpoint checkup it was successful.
2.Restarted the JBOSS 

 

 

Environment

Release : 14.2

Component :

Cause

A review of the logs show a space allocation issue at the database:

07:17:01,171 ERROR [com.eurekify.services.BuildingBlockServiceImpl] (taskExecutorServiceContainer-6) [Universe [universe_1], Flow [1257], Task [4484585], Job [16576:WPDS], Activity [198261:WPDS], Node [Create Temp Configuration]] - Process [qAggImport] - Error while executing building block com.eurekify.businessflow.bb.multiimport.CreateTempConfigurations: org.springframework.jdbc.BadSqlGrammarException: PreparedStatementCallback; bad SQL grammar [INSERT INTO BBExecutionContexts (ContextId, UUID, JobId, ActivityId, TaskId, BusinessFlowId, WaitKey, CreationDate, ExecutionStatus, NodeName, Result )  VALUES (?, ?, ?, ?, ?, ?, ? ,? ,? ,? ,? )]; nested exception is com.microsoft.sqlserver.jdbc.SQLServerException:
Could not allocate space for object 'dbo.qExecutionContexts'.'U_qExecutionContexts' in database 'ig_db' because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup.

 at org.springframework.jdbc.support.SQLStateSQLExceptionTranslator.doTranslate(SQLStateSQLExceptionTranslator.java:98) [spring-jdbc-3.0.6.RELEASE.jar:3.0.6.RELEASE]

Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: Could not allocate space for object 'dbo.qExecutionContexts'.'U_qExecutionContexts' in database 'ig_db' because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup.

Resolution

Work with the DBA to increase available space for the database indicated in the error, in the above log exert, 'ig_db'
Once space has been increased restart Governance and resubmit any stuck Campaigns.