Broadcom API Gateway 10.1 CR2 - Log View in Policy Manager do not show log files for all nodes in the cluster
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Broadcom API Gateway 10.1 CR2 - Log View in Policy Manager do not show log files for all nodes in the cluster

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Article ID: 250141

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Updated On:

Products

CA API Gateway

Issue/Introduction

Post applying Cumulative Release patch CR2 in Gateway 10.1, Policy Manager users are unable to retrieve logs for all nodes in the same cluster via View > View Logs

An error is shown in the SSG log:

2022-09-12T22:08:01.393+0800 WARNING 661 com.l7tech.server.log.SinkManager: Unexpected error during log list/read from remote node '<node ID>':Could not access HTTP invoker remote service at [https://securespangateway/ssg/cluster/LogAccessAdmin]; nested exception is javax.net.ssl.SSLPeerUnverifiedException: Invalid peer: <node hostname>

 

Environment

Release : 10.1

Component : Policy Manager

Cause

This is a known bug (DE545252) caused by an updated Http library that enforces a hostname verification.

While getting logs from other nodes in the cluster, the current node which the user is logging into it via Policy Manager is not trusting the remote host nodes.

Resolution

A new CR2 is now available and is free from this issue.