After updating LDAP service account password - no users can login to DX Netops Spectrum
search cancel

After updating LDAP service account password - no users can login to DX Netops Spectrum

book

Article ID: 250121

calendar_today

Updated On:

Products

Spectrum Network Observability

Issue/Introduction

Service Account password changed for connection to the LDAP host.

Updating to the new password in Spectrum LDAP Configuration no users are able to login.

Environment

DX NetOps Spectrum all currently supported releases

Cause

Misleading instructions presented to users on the OC Administration sites LDAP Configuration page.

Resolution

A Spectrum Tomcat restart is required to resolve this issue.

Although the UI indicated a restart is not required for changed.

Updated in 21.2.6+:

  • This release enhances password security by masking the user-defined passwords in the GUI and configuration files. You must manually re-enter the password in the following scenarios:
    • Enable or disable the integrations
    • Test the integrations
    • Add or remove the servers

This is the reason a restart is required.  

Additional Information

Defect DE168193 was submitted to have this resolved. Watch the Spectrum Resolved Issues page for the release that includes DE168193 and it's resolution.