Error 'The credentials for the asset (asset_name) have not been specified' when running a CCS agent based data collection
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Error 'The credentials for the asset (asset_name) have not been specified' when running a CCS agent based data collection

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Article ID: 250078

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Updated On:

Products

Control Compliance Suite Standards Server Control Compliance Suite

Issue/Introduction

Control Compliance Suite (CCS)

When running a data collection on a CCS agent, you get the following error about credentials:

The credentials for the asset (asset_name) have not been specified

Environment

Release : CCS 12.5.x and 12.6.x

Component : CCS Agent

Cause

In an agent based data collection CCS environment, each CCS agent will have at least one Asset associated with it.  If the agent gets removed/deleted from CCS without also deleting all associated Assets, then when a data collection is run on that Asset CCS will think that is it as an Agentless data collection and look for credentials for CCS to use to run the scan on that remote server.  Since you don't use credentials to collect data on servers that have a CCS agent, you will get the error that there is no credentials to use for agentless data collection.

NOTE: The CCS agent does not need credentials for OS data collection, but it may (depending on how it is configured) need credentials specified for data collections on MSSQL databases, Oracle databases, etc.

Resolution

To make sure there are no orphaned assets, do the following:

  1. Delete all assets associated with that server from CCS.
  2. Reinstall the agent (if necessary) on that server and/or reregister it to CCS.
  3. Run the 'Fetch Registered Agents' job to pull in the newly registered agent xml files from the managers.
  4. Once the agent now has the Asset associated correctly, run a data collection on that asset.

Additional Information

There can be scenarios that the Asset for an agent is deleted from CCS and not the agent, so there will be no way to collect data for that agent as there is no Asset.  To make sure all your agents have an associated Asset, look in the CCS console in the 'Asset System' -> 'Agents' section, and then click on the folder 'Agents Without Assets' in the left had column.  Any agents listed in this folder should be deleted in CCS, and then reregister those CCS agents on those servers back to a manager (and a 'Fetch Registered Agents' run to bring in the agent xml into CCS) to have an Asset created for those agents.