DX NetOps Mediation Manager - After upgrading Performance Management neither the Engine or Presenter will start.
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DX NetOps Mediation Manager - After upgrading Performance Management neither the Engine or Presenter will start.

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Article ID: 250030

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Updated On:

Products

Network Observability CA Mediation Manager

Issue/Introduction

DX NetOps Mediation Manager - After upgrading Performance Management neither the Engine or Presenter will start.

Example Errors:

Presenter:

SEVERE: Fatal Exception occurs in Presenter
java.lang.reflect.InvocationTargetException
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.base/java.lang.reflect.Method.invoke(Unknown Source)
        at com.torokina.tim.classloader.TimBootstrap.bootstrap(TimBootstrap.java:80)
        at com.torokina.tim.presenter.Main.main(Main.java:90)
Caused by: java.lang.NullPointerException
        at com.torokina.tim.communication.protocol.license.PresenterLicenseRequester.isSuccess(PresenterLicenseRequester.java:38)
        at com.torokina.tim.presenter.PresenterServer.checkPresenterLicense(PresenterServer.java:242)
        at com.torokina.tim.presenter.Main.boot(Main.java:140)
        ... 6 more

Engine:

SEVERE: Exception while handling device list file
java.lang.NullPointerException
        at com.torokina.tim.communication.protocol.license.EngineLicenseRequester.getAllocatedNum(EngineLicenseRequester.java:39)
        at com.torokina.tim.engine.poller.InventoryAcquisitionInvoker.requestEngineLicense(InventoryAcquisitionInvoker.java:317)
        at com.torokina.tim.engine.poller.InventoryAcquisitionInvoker.invoke(InventoryAcquisitionInvoker.java:172)
        at com.torokina.tim.engine.poller.InventoryThread.run(InventoryThread.java:100)
        at java.base/java.lang.Thread.run(Unknown Source)

Cause

Mediation Manager services were hung due to relying on the Data Collector's or Performance Management's Java installation and that was upgraded.

Resolution

All Mediation Manager services must be stopped on the MC and LC through the stopall scripts.  If any processes are unable to be stopped (very likely) you will need to kill -9 the processes.  You can find out what the process is by

1. The port will be called out in the failed stopall command

2. Take that port and look for the process id with a command like: netstat -anp | grep :port

3. Take the process id from step 2 and run: kill -9 process_id

From there run the cammstatus utility to ensure all are stopped, followed by the startall script to start things again.  Please note that this will need to be done on the MC and all LC servers as changing out the java caused some of the MM processes to hang.