Global Synchronization fails for Domain Groups post 22.2.1 upgrade
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Global Synchronization fails for Domain Groups post 22.2.1 upgrade

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Article ID: 250020

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Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration CA Spectrum

Issue/Introduction

The DX NetOps Performance Management Portal web server was upgraded.

We upgraded the Data Repository, the Data Aggregator, the Data Collectors and then the Portal web server was upgraded last.

We see a Red icon in System Status. When reviewing it we see the Global Synchronization table showing a Red icon.

After the upgrade to 22.2.x we see a Global Synchronization (GS) failure. The Global Sync (GS) failure shows against the Domain Groups section of the GS processing.

The following error would be seen in the (default path shown) /opt/CA/PerformanceCenter/DM/logs/DMService.log file. It references an "Exception thrown by sync task: org.springframework.jdbc.BadSqlGrammarException: PreparedStatementCallback; bad SQL grammer [INSERT INTO temp_changed (ItemID, DomainGroupID, ItemType, ItemSubType) SELECT t.ItemID, tg.ItemID, i.ItemType, t.ItemSubType FROM t_network_path...".

The root error reported is "...nested exception is java.sql.SQLSyntaxErrorException: Unknown column 't.DomainID' in 'on clause'".

Environment

All supported DX NetOps Performance Management releases

Cause

Changes to the tool require the components get upgraded in a defined order. Varying from the defined, documented order of upgrade can lead to errors.

Most importantly, if you update one of the data sources (DS) before the portal, this issue will be seen.

This is caused by a new table in the DB: t.DomainID

Resolution

To avoid the problem ensure the systems are upgraded in the correct order which starts with the Portal web server.

To resolve the problem once observed run a Full Synchronization of the Data Aggregator (DA) Data Source (DS).

  1. Go to Administration -> Data Sources -> Data sources
  2. Select the Data Aggregator Data Source
  3. Select the Resync button.
  4. Select the Perform a Full Resynchronization checkbox.
  5. Select the Resync button.

 

When the DA DS completes it's resync the next GS cycle should complete without error.

Additional Information

If this does not resolve the problem open a new support case for further assistance.