Unable to see QOS metrics for one of the servers in Operator Console (OC)
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Unable to see QOS metrics for one of the servers in Operator Console (OC)

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Article ID: 250018

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

Need help to resolve issue as we are unable to see any metrics (CPU, memory, disk etc) for one of the servers over the past couple of days.

Environment

  • Release: 20.3.3, 20.4, 23.4 or higher
  • Component: UIM - CDM WITH IOSTAT

Cause

  • host(s)/devices were blacklisted

Resolution

The device/server showing no metrics was blacklisted.

When this is done the device is added to the CM_BLACKLIST_DEVICE table. 

discovery_server ignores all devices listed in that table. 

To remove a device from the blacklist:

Go to Admin Console -> discovery_server ->'View Probe Utility in New Window.
'clear_all_blacklisted_devices < to remove all devices from the blacklist 

unblacklist_devices <to remove one or more from the blacklist>
- this callback requires the blacklist_id which is obtained from CM_BLACKLIST_DEVICE bl_id column (see below)

Helpful queries:

SELECT * from CM_BLACKLIST_DEVICE;  <to show all devices in the table>
SELECT * from CM_BLACKLIST_DEVICE where dev_ip = ‘xxx’;  <search by IP>
SELECT * from CM_BLACKLIST_DEVICE where dev_name = ‘xxxx’; <search by name>