Identity Portal: error connecting to Identity Governance -Address already in use
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Identity Portal: error connecting to Identity Governance -Address already in use

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Article ID: 249708

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Updated On:

Products

CA Identity Suite

Issue/Introduction

The customer is using the Identity Portal to run Identity Governance certification campaigns and experienced an issue on the Identity Portal that prevented the users from running certification campaigns: the connection to IG could not be established, as shown in the logs:

11:59:02,411 INFO  [stdout] (default task-1988) [SIGMA APPENDER - FROM WEB] 2022-08-12 11:59:02,409 - WARN org.apache.cxf.phase.PhaseInterceptorChain - Interceptor for {http://xxx.xx.x:8080//eurekify/rest}WebClient has thrown exception, unwinding now 
11:59:02,411 INFO  [stdout] (default task-1988) org.apache.cxf.interceptor.Fault: Could not send Message.

....

11:59:02,414 INFO  [stdout] (default task-1988) Caused by: java.net.BindException: Address already in use: connect

....

11:59:02,415 ERROR [com.idmlogic.sigma.workers.utils.ExceptionsHelper] (default task-1988) : javax.ws.rs.ProcessingException: java.net.BindException: BindException invoking http://xxx.xx.x:8080/eurekify/rest/idp/configurations/Eurekify/users/search?userId=UXXXX: Address already in use: connect

Environment

Release : 14.4

Component : IdentityMinder(Identity Manager)

Cause

Usually this kind of issue occurs when the address/port is already being used. This can also occur when a previous shutdown/restart did not clear an address/port.

Resolution

Please run the "netstat -ban" command to see if any process is already using the address/port.