Broadcom API Gateway Software 10.x - AWS Solution Kit fails to be installed
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Broadcom API Gateway Software 10.x - AWS Solution Kit fails to be installed

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Article ID: 249676

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Updated On:

Products

CA API Gateway

Issue/Introduction

When attempting to install AWS Solution Kit the installation fails and Policy Manager generates a stack trace:

 org.springframework.remoting.RemoteAccessException: Could not access HTTP invoker remote service at [https://securespangateway/ssg/manager/SolutionKitAdmin]; nested exception is java.net.SocketException: Connection reset by peer: socket write error
 at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.convertHttpInvokerAccessException(HttpInvokerClientInterceptor.java:234)
 at org.springframework.remoting.httpinvoker.HttpInvokerClientInterceptor.invoke(HttpInvokerClientInterceptor.java:160)
 at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:186)
 at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:215)
 at com.sun.proxy.$Proxy33.testInstallAsync(Unknown Source)
 at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
 at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
 at java.base/java.lang.reflect.Method.invoke(Unknown Source)
 at com.l7tech.gateway.common.spring.remoting.http.a.call(Unknown Source)
 at com.l7tech.gateway.common.spring.remoting.http.SecureHttpComponentsHttpInvokerRequestExecutor.doWithSession(Unknown Source)
 ...

Environment

API Gateway 10.1 Software form factor

Cause

A common reason that causes this issue is insufficient memory allocated to Java Heap size.

Further SSG log analysis can pin-point the root cause:

2022-09-05T12:01:32.652+1000 WARNING 69 com.l7tech.external.assertions.gatewaymanagement.server.ServerRESTGatewayManagementAssertion: 9050: Error processing management request: Exception encountered processing a rest message: java.lang.OutOfMemoryError: Java heap space. Caused by: Java heap space

Contrarily to Gateway Appliance where we use a script to automatically allocate half of the physical memory to JVM, the Software form factor requires manual tuning.

Resolution

 

  • Ensure the system meets the minimum recommended resource allocation as documented in Software Gateway Specifications   
  • Allocate at least 8GB of RAM for non-production environment (e.g. Test/UAT/SIT) and 16GB for production. 
  • Either reconfigure the Gateway via /opt/SecureSpan/Gateway/runtime/bin/setup.sh script and specify a new value for JVM Heap Size or edit node.properties and assign half of the physical RAM via node.java.heap=<value> property (value must be in MB), for example, with 8GB of RAM allocated, the property should be like:

node.java.heap=4096

  • Restart the Gateway to allow changes to be effective