CEM enabled agents are attempting to connect to SMP/Notification Server directly and failing with error: "No such host is known"
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CEM enabled agents are attempting to connect to SMP/Notification Server directly and failing with error: "No such host is known"

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Article ID: 249640

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Updated On:

Products

IT Management Suite

Issue/Introduction

CEM enabled agents are only attempting to connect to the SMP/Notification Server directly and are failing. In the agent logs we see no attempts to connect through the internet gateway.

All attempts to connect directly to the NS/SMP fail with error "No such host is known"

Agent is starting and the CEM mode is 'Enabled', the registration status shows as 'Not registered' and the following error is received:

Request 'HTTPS://<SMP.FQDN>:443/altiris/NS/Agent/ConnectionTest.asp' failed, COM error: No such host is known (0x80072AF9)

Environment

ITMS 8.x

Cause

It was discovered that the CEM policy configured in the SMP Console had the internal name of the Internet Gateway and not the external FQDN or IP.

Resolution

After adding the external resolvable FQDN or IP address to the gateway policy (with the correct thumbprint), then re-generating the CEM agent installation package and installed, the issue was resolved.