Unable to login to AdminUI using registered administrators/users from external user store
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Unable to login to AdminUI using registered administrators/users from external user store

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Article ID: 249499

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Updated On:

Products

SITEMINDER CA Single Sign-On

Issue/Introduction

"Configure Administrative Authentication" was configured such that AD users can logon to AdminUI.
Multiple AD users were registered as SiteMinder administrators so they can logon to AdminUI.
Then, AdminUI was reset through deletion of the data folder (<CA>\siteminder\adminui\standalone\data\).
The 'siteminder' user can login to AdminUI but all previous AD users can no longer login.
The error prompted on-screen was "Username and Password do not match", even though correct username and password was submitted.

Environment

Release : 12.8
Component : SITEMINDER WAM UI

Cause

When the "Configure Administrative Authentication" is configured, the file xxxxxxx.xml (in <CA>\siteminder\adminui\standalone\data\siteminder\directories\) gets generated. Its information is used by AdminUI to directly connect to the AD server.
As the data folder was deleted, the XML file was removed as well, resulting in AdminUI being unable to connect to the AD server to validate the username and password.

Resolution

Re-enabling administrators from an external user store
(in AdminUI: Administration > Admin UI > Configure Administrative Authentication):

Redo the "Configure Administrative Authentication" the exact same way how it was configured before.
Refer to the documentation on how to Configure the Connection to the External Administrator Store.
Once configured, previously registered external administrators will once again be able to access AdminUI.

Additional Information

Note that upon successful implementation of the Configure Administrative Authentication wizard, AdminUI will restart automatically