SEVERE: Servlet.service errors - Tomcat log
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SEVERE: Servlet.service errors - Tomcat log

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Article ID: 249375

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Updated On:

Products

CA Spectrum

Issue/Introduction

We are observing some errors in Tomcat logs. Just wanted to run it by support to see if its impacting anything or harmful.

ERROR DefaultDispatcherErrorHandler Exception occurred during processing request: java.lang.NullPointerException
 org.apache.jasper.JasperException: java.lang.NullPointerException

 

Environment

Release : 20.2.x / 21.x / 22.x

Component : Spectrum OneClick

Cause

 I have reviewed the tomcat logs of this issue... There are few NullPointerExceptions in the logs and they are for 2 different reasons. The below NPE is specific to tomcat itself and our spectrum application is not involved as part of this exception:
ERROR DefaultDispatcherErrorHandler Exception occurred during processing request: java.lang.NullPointerException
Ideally exceptions should not be thrown in any setups... but as this above exception does not include any spectrum related code in its stack trace it will not impact spectrum application.


The second NPE has our spectrum code in its stack trace:
SEVERE: Servlet.service() for servlet [jsp] threw exception
java.lang.NullPointerException
    at com.aprisma.util.resource.LocaleStringKey.hashCode(LocaleStringKey.java:71)
    at java.util.HashMap.hash(HashMap.java:339)
    at java.util.HashMap.get(HashMap.java:557)
and this second exception root cause is pointing to alarm_002dpcause_jsp.java. 

This alarm_002dpcause_jsp.java file is created from jsp pages and gets stored in tomcat/work/Catalina directory. In these exception scenarios the first steps is to clear the tomcat/work directory so that any corruptions in the conversion of jsp to java files will be avoided. So we would like to request to first try clearing tomcat/work directory and restart tomcat to see if any further exceptions are reported where spectrum code is involved.

 

PS: As updated earlier its not good to have exceptions. The impact may not be reflecting straight away but it may have somewhere or other
As SE mentioned please follow the steps first and then see further on this.

Resolution

The patch  Spectrum 10.4.1_BMP_10.4.102. was released on 3rd Nov 2020 which was after 10.4.2 release, so this is not included in the version you are on. We would request you to upgrade to 10.4.3 or to the latest versions Dx NetOps 21.2.12.

https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/release-announcements/CA-Spectrum-Release-and-Support-Lifecycle-Dates/6848