Process Monitoring shows 500+ Tasks instead of Real number of Activities in Client
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Process Monitoring shows 500+ Tasks instead of Real number of Activities in Client

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Article ID: 249298

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation Automic SaaS

Issue/Introduction

From the Administration Perspective - Client shows a higher number of activities - However while checking the Process Monitoring the number of Activities shown are much less.

Environment

Release : 12.x 

                 21.x

                 24.x

Component : Automation Engine

Functional Area : AWI 

Cause

This is as per design - The list displays records according to the specified filter settings in UC_SYSTEM_SETTINGS > COMBINED_ACTIVITIES_LIMIT. If the process monitoring search result returns more tasks than the value entered here, the system indicates + on the list, next to the value defined [Example: 500+ ].

  • Default value: 500

This is why you may run into scenarios where the number of activities in the client are higher, whilst the process monitoring perspective show you 500+.

Resolution

You can increase this value in the UC_SYSTEM_SETTINGS variable  on client 0.

If there is no entry in the variable - It means that the default value of 500 is being used - You can manually add the COMBINED_ACTIVITIES_LIMIT Key and specify the limit you would like to have on the Value1 column.

Example:

  • Restart required: No restart is required for this setting to take affect.

However the recommended best practice would be to not have a very high number - This would have an impact on the Automation Engine Performance.

You should regularly housekeep your Process Monitoring perspective and also carry out the recommended DB maintenance procedures.

Additional Information