CA/1 Errors with LU05200 - CALR819E error from EARL report TMEDSN01 and U3000 abends.
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CA/1 Errors with LU05200 - CALR819E error from EARL report TMEDSN01 and U3000 abends.

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Article ID: 249247

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Updated On:

Products

CA 1 Tape Management Earl

Issue/Introduction

Added maintenance last night.  EARL print dsn master listing report TMEDSN01 is now failing with CALR819E error, U3000. 
Maintenance included PTF LU05200.

 

Environment

CA 1 Tape Management R14.0

Cause

PTF LU05200 - Introduced significant enhancement but also introduced a few errors.
The PTF has now been marked as PE. There are a number of corrective PTF's.

A new field MAXRETPD was added.  Under some conditions, bad data is left within this field.

This causes U3000 abend in EARL processing on TMS housekeeping jobs.
It can also cause S0C7 in DB2 tape processing after the PTF is installed.

Resolution

Firstly consider if the TMC is shared across LPAR's and if all maintenance has been applied across all LPARs.

Resolution is a 3 step process.

  1. Ensure all correcting PTF's are installed - refer information below
  2. Run TMSCKDTM and forward the complete output to Support so we can create the corrective input for TMSUDSNB
  3. Run TMSUDSNB with the file provided by support

 

If LU05200 is installed need to ensure the following PTFs are installed. 

LU05198
LU05824
LU05858
LU05860
LU05968
LU06346
LU06373
LU06376
LU06984
LU06985
LU07148
LU08199
LU08485

Need to ensure TMSCKDTM runs cleanly.  If not, raise a new case and forward the complete output for review.

Once you have received the corrective file, run TMSUDSNB utility pointing SYSIN DD to file you received from Support.
This will cleanup the MAXRETPD fields reported in error.

 

Additional Information

Need to ensure the SHUTDWN PASSWORD is set correctly.
There no impact on running this job on batch processing.

You should also BACKUP the TMC and Audit (TMSCOPY) after completion.