Unable to open Add/Update licenses page in SIM. Error: Unable to load licenses from NS server.
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Unable to open Add/Update licenses page in SIM. Error: Unable to load licenses from NS server.

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Article ID: 249226

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Updated On:

Products

IT Management Suite

Issue/Introduction

The customer is trying to open "Add/Update licenses" page in the SIM (Symantec Installation Manager) main page but it doesn't load. Other options also behaves similarly.

The NS logs showed the following error message:

Unable to load licenses from NS server.
The request failed with HTTP status 401: Unauthorized.
   [System.Net.WebException @ System.Web.Services]
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Altiris.NS.Licensing.LicensingWebServiceProxy.GetLicenseStatus()
   at Symantec.Installation.Model.LicenseManager.<LoadLicensesFromServer>d__33.MoveNext()
   at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
   at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
   at Symantec.Installation.Model.LicenseManager.LoadFromServer(Func`1 getLicXml)
   at Symantec.Installation.Model.LicenseManager.LoadLicenses()

Exception logged from: 
   at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   at Symantec.Installation.Logging.LogActivity.ReportException(String strMessage, String category, Exception exception)
   at Symantec.Installation.Model.LicenseManager.LoadLicenses()
   at Symantec.Installation.Model.LicenseManager.RefreshLicenses(Boolean force)
   at Symantec.Installation.Context.SimApplicationContext.ProductListingManager_LoadAndUpdateProductListingCompleteEvent(Object sender, CompleteEventArgs e)
   at Symantec.Installation.Managers.ProductListingManager.LoadAndUpdateProductListings()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()


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Date: 31/08/2022 16:14:04, Tick Count: 8986265 (02:29:46.2650000), Size: 2,25 KB
Process: SimConsole.dll (7028), Thread ID: 6, Module: SimConsole.dll.exe
Priority: 1, Source: Symantec.Installation.Model.LicenseManager.LoadLicenses

Environment

ITMS 8.5, 8.6

Cause

The customer was running an old version of SIM. In this case it was 8.5.5006. The current one was 8.6.4037. The customer was pointing to a local repository for SIM rather than to our external site. So SIM was never aware that there was a newer version of itself to be installed.

Resolution

Upgrade SIM to the most recent version of SIM. SIM needs recent updates in order to load license references properly.

 

When SIM launches, it should recognize that there is a new version to be installed if it is pointing to our default location. If you don't a prompt for upgrading, make sure you are pointing to our default repository: