Unknow able to access oidc .well-known/openid-configuration
search cancel

Unknow able to access oidc .well-known/openid-configuration

book

Article ID: 249117

calendar_today

Updated On:

Products

SITEMINDER CA Single Sign On Agents (SiteMinder) CA Single Sign On Secure Proxy Server (SiteMinder)

Issue/Introduction

Unable to access .well-known/openid-configuration link on a new oidc client.

https://www.<host name>.<Your domain>/affwebservices/CASSO/oidc/clientname/.well-known/openid-configuration

The error could be:

Server Error. The server was unable to process your request.

Or

HTTP Status 404 – Not Found


Type Status Report

Message Bad request.

Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists

Environment

Release : 12.8.05

Component : SITEMINDER SECURE PROXY SERVER

Cause

Configuration prerequisites were not met.

Resolution

There are prerequisites before browser can access to this well-known url.

  • If you are upgrading to SiteMinder 12.8.02 or later, ensure that you upgrade Access Gateway too.
  • Remove the /. pattern in the BadUrlChars parameter of the Access gateway agent configuration object.
  • Under admin ui, OpenID Connect-->Client->clientname, "" check box must be checked for this particular Client.

 

Additional Information

https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/siteminder/12-8/configuring/use-siteminder-as-openid-connect-provider/discovery-profile-of-provider-metadata.html