Bay Dynamics AD Connector Job failure
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Bay Dynamics AD Connector Job failure

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Article ID: 249090

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Updated On:

Products

Information Centric Analytics

Issue/Introduction

The Bay Dynamics AD Connector Job is failing. The importer log indicates this is due to a failed insert into the column IsEnabled, which is not present in the Server table in the ActiveDirectoryDW database.

Environment

Release : 6.5.4

Component : Active Directory Import Utility

Cause

The ActiveDirectoryDW.Server table was not updated after upgrading to a version of the Active Directory Import Utility prior to 1.6.0.0.

Resolution

Set the value of the column ActiveDirectoryDW.BayDynamics_ADConnector_System.Version to 1.5.6.0 and then re-run the Bay Dynamics AD Connector Job to force the importer to update the ActiveDirectoryDW database and tables.

Alternatively, using the column names in the ActiveDirectoryDW.Server table on a working 1.6.3.0 installation as a reference, run an ALTER statement to add the missing columns with correct data types to the server and then run the Bay Dynamics AD Connector Job to validate the fix.