Request Sets with flex parameters cannot be launched with Dollar Universe
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Request Sets with flex parameters cannot be launched with Dollar Universe

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Article ID: 248979

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Updated On:

Products

CA Automic Dollar Universe

Issue/Introduction

Some Request Set Jobs are failing as the Manager for OAPP does not seem capable of resolving correctly a Flex parameter value:


From KEPR02_AR.txt - set BATAMAR NIGHTY with parameter Seq 15 - Batch Source Name defined as

SELECT NAME FROM RA_BATCH_SOURCES WHERE BATCH_SOURCE_ID = :$FLEX$.RA_AUTOINV_BATCH_SOURCE

We can see in the job log that in DUAS side it fails to calculate it:

2021-07-28 12:32:03 - ComputeHiddenId - Execute SQL statement to find the hidden id
2021-07-28 12:32:03 - ComputeHiddenId - select BATCH_SOURCE_ID from RA_BATCH_SOURCES WHERE BATCH_SOURCE_TYPE = 'FOREIGN' and NAME = 'ETBF INVOICES'
2021-07-28 12:32:03 - ComputeHiddenId - NO integer DATA FOUND for this SQL statement
2021-07-28 12:32:03 - ComputeHiddenId - Exit

But if we launch the following in Oracle SqlDeveloper:

EXEC MO_GLOBAL.SET_POLICY_CONTEXT('S','9824');
select BATCH_SOURCE_ID from RA_BATCH_SOURCES WHERE BATCH_SOURCE_TYPE = 'FOREIGN' and NAME = 'ETBF INVOICES'

The result in Oracle is 1642 - so somehow Dollar Universe seems to have an issue in ComputeHiddenId function

As a result the request is submitted with wrong parameters in Dollar Universe opposed to when it's launched manually in OEBS end.

ORSYP:
MAIN, T, ETBF INVOICES, "", 2021/08/04 09:33:01, , , , , , , , , , , , , , , , , , , , , N, Y, , ""

OEBS:
MAIN, T, 1642, ETBF INVOICES, 2021/08/05 00:00:00, , , , , , , , , , , , , , , , , , , , , N, Y, , 9824

Environment

Release : 6.x

Component : Dollar Universe

Sub-Component: Manager for Oracle Application (OEBS)

Cause

Defect when calculating a Flex parameter value in ux_conc_request_set_du6.sql or ux_get_default_params_du6.sql

Resolution

This problem would be fixed via a new case opened as soon as customer provides a OEBS cloud environment that can be used from Broadcom side to fix the problem

Additional Information

Should you encounter this problem, please open a new case with Technical Support referencing DU_AS-6011