CAPKI errors when starting the SpectroSERVER process on Linux
search cancel

CAPKI errors when starting the SpectroSERVER process on Linux

book

Article ID: 248968

calendar_today

Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

Aug 25 14:32:19 : Please wait. SpectroSERVER
     is loading landscape 0xdb00000 at precedence 10...

       Number of models loaded      : 0     Could not get function dispatch table for CAPKI library
SPC-SHD-29021: 
**************************************************************************
The following output is intended to facilitate debugging, please forward
to CA technical support.  The files listed are not part of the customer
installation of SPECTRUM.
**************************************************************************

Aug 25 14:32:29 ERROR TRACE at SnmpV3ProfileGlobalConfigIH.cc(227): SnmpV3ProfileGlobalConfigIH:Cannot initialize the CAPKI library

Environment

Release : Any
Component : SpectroSERVER

Cause

Missing CAPKI libraries

Resolution

To resolve the issue, first ensure there is plenty of space in the /opt directory. If not, free up space for the CAPKI files

When there is enough space, reinstall CAPKI by doing the following:

- Log into the SpectroSERVER system as the user that owns the Spectrum installation

- Shutdown the SpectroSERVER process

- su or sudo su to the root user

- cd to the$SPECROOT/Install-Tools/CAPKI directory and enter the following command:

./setup install caller=SPECTRUM env=all

- Start the SpectroSERVER as normal and verify there are no more CAPKI errors