CAPKI errors seen in the VNM.OUT during SS startup "ERROR TRACE at SnmpV3ProfileGlobalConfigIH.cc(227): SnmpV3ProfileGlobalConfigIH:Cannot initialize the CAPKI library" SPC-SHD-29021
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CAPKI errors seen in the VNM.OUT during SS startup "ERROR TRACE at SnmpV3ProfileGlobalConfigIH.cc(227): SnmpV3ProfileGlobalConfigIH:Cannot initialize the CAPKI library" SPC-SHD-29021

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Article ID: 248968

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Updated On:

Products

Spectrum Network Observability

Issue/Introduction

Seen in the VNM.OUT during SS startup

 

Could not open CAPKI shared library, errno is 22, errmsg is /opt/CA/SharedComponents/CAPKI/CAPKI5/Linux/amd64/64/lib/libcapki.so: cannot open shared object file: No such file or directory

SPC-SHD-29021:

**************************************************************************

The following output is intended to facilitate debugging, please forward

to CA technical support.  The files listed are not part of the customer

installation of SPECTRUM.

**************************************************************************

 

May 07 12:19:20 ERROR TRACE at SnmpV3ProfileGlobalConfigIH.cc(227): SnmpV3ProfileGlobalConfigIH:Cannot initialize the CAPKI library

Environment

Release : Any
Component : SpectroSERVER Core

Linux

Cause

Missing CAPKI libraries

Resolution

To resolve the issue, first ensure there is plenty of space in the /opt directory. If not, free up space for the CAPKI files

When there is enough space, reinstall CAPKI by doing the following:

- Log into the SpectroSERVER system as the user that owns the Spectrum installation

- Shutdown the SpectroSERVER process

- su or sudo su to the root user

- cd to the$SPECROOT/Install-Tools/CAPKI directory and enter the following command:

./setup install caller=SPECTRUM env=all

- Start the SpectroSERVER as normal and verify there are no more CAPKI errors