Hostname blank on several devices.
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Hostname blank on several devices.

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Article ID: 248923

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Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

Hostname blank on several devices.

 

Environment

Release : 21.2

Component : PM Data Aggregator

Cause

If we are not able to resolve the hostname through DNS at its the first time of the device discovery, we will NOT perform the name lookup every 24 hours.   We only perform the 24-hours hostname lookup for the device items that already have a hostname resolved.

Resolution

 Get the ID of the device. Just go to Administration -> Monitored Items Management ->Monitored devices. Pull up the device and on the details page and the ID we need is the "Item ID:" 

Then do a REST PUT of this body replacing HOSTNAME with the one you want. 

<Device version="1.0.0">
<HostName>HOSTNAME</HostName>
</Device>

To this URL replacing <DA_SYSTEM> with the name or ip of your DA. 

http://<DA_SYSTEM>:8581/rest/devices/<Item ID:>