Symantec Identity Manager - The endpoint type that was referenced in the request has not been activated.
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Symantec Identity Manager - The endpoint type that was referenced in the request has not been activated.

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Article ID: 248913

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Updated On:

Products

CA Identity Suite CA Identity Manager

Issue/Introduction

After creating a new endpoint through Connector Xpress, the error "The endpoint type that was referenced in the request has not been activated." is thrown when trying to create a new endpoint.

Environment

Release : 14.4

Component : IdentityMinder(Identity Manager)

Cause

The issue was caused by a corrupted connector.xml. (Location: "Connector Server\jcs\conf\override\jndi\connector.xml") that contained duplicate entries. The override jndi may not be the proper connector.xml to view depending on the datasource that is being used within Connector Xpress.

Resolution

For troubleshooting purposes, it is best to rename the existing connector.xml to connector.xml.old and then restart the connector server. This will allow the connector server to use default values instead of declared values within the connector.xml.

Once the file has been renamed and the connector restarted try to create the endpoint, it should be successful this time around.