Unable to Repair ITMS. Error: Failed to construct DatabaseContext object. Connection to database failed.
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Unable to Repair ITMS. Error: Failed to construct DatabaseContext object. Connection to database failed.

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Article ID: 248912

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Updated On:

Products

Asset Management Suite Client Management Suite IT Management Suite Server Management Suite

Issue/Introduction

When attempting a repair, the following error occurred:

A critical error occurred:

Altiris.NS.Exceptions.DatabaseNotReadyException: Failed to construct DatabaseContext object. Connection to database failed.

Login failed. The login is from an untrusted domain and cannot be used with integrated authentication. 

 

Environment

Release: 8.6.x

Cause

Authentication error when accessing the database during repair.

Resolution

Note: For any repair or upgrade, ensure that you log into the Notification Server with the Application Identity (Service) account.

  • Using the Symantec Installation Manager, click the Configure Settings link.
  • Click Configure Database Settings to set it to bold if it is not already bold and then click Next.
  • Ensure the SQL server name and Database selection is correct, and click the Refresh button.
  • If there are any warnings, these need to be addressed.
    • In this case, switching from Windows Authentication to Use SQL Server login corrected the issue.