Jobs remain pending with uxjobinit saying (Winsock): Invalid argument
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Jobs remain pending with uxjobinit saying (Winsock): Invalid argument

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Article ID: 248885

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Updated On:

Products

CA Automic Dollar Universe

Issue/Introduction

Suddenly, a node that used to work fine stops submitting all Jobs launched with a particular Service Account, the Windows Service related to the account is properly started and well configured in Dollar Universe.

When launching the Jobs, we observe that they remain in Pending status for a very long time and that the following error messages are written in the Uproc Job log by the uxjobinit process:

Error Connecting to IO Server: o_connect_auth_returns -1:(Winsock): Invalid argument
Error getting conf from IO Server: o_get_conf_from_io returns -1
Cannot load environment
The syntax of the command is incorrect.

We observe at system level that the uxjobinit process is unable to connect to the uxioserv in the related port (10600), which explains the errors above.

Environment

Release : 6.x

Component : DOLLAR UNIVERSE

Cause

Unknown, most likely a security tool that does not allow using ephemeral ports to the Windows Service Account.

Resolution

Workaround:

Use the  administrator (Localsystem) submission account instead of the domain account

Additional Information

If you are encountering this issue, please open a case with Microsoft to investigate why the process uxjobinit launched as the Domain Account cannot connect to the uxioserv process using an ephemeral port.

Troubleshooting could be started disabling or white-listing the <dollar_universe_folder>/bin/u* processes on the Antivirus/Security tool see if the issue continues to occur or not.

Then, it can be tried to use another Domain Account or Local Account as a Submission Account in Dollar Universe and check if the problem also occurs.