Service Unable to start ActiveMQ after numerous retries
search cancel

Service Unable to start ActiveMQ after numerous retries

book

Article ID: 248604

calendar_today

Updated On:

Products

CA Process Automation Base

Issue/Introduction

Orchestrator service failed to start with below error messages.
c2o.log shows:
ERROR [com.optinuity.c2o.c2oserver.ServerManager] [ Initialization] Unable to start ActiveMQ after numerous retries, hence shutting down the PAM server...

activemq.log shows:
INFO | The connection to 'tcp://xxx.xxx.xxx.xxx:60649' is taking a long time to shutdown. | org.apache.activemq.broker.TransportConnection | ActiveMQ ShutdownHook

Environment

Release : 4.3.X

Component : Process Automation

Cause

Due to outage happened, Orchestrator service was stopped abnormally with a java.exe left in task manager.

Resolution

Before starting Orchestrator service, verify any java.exe is running in task manager (believe ITPAM is the only Java based application in the server).
If it is, kill the java.exe and then start Orchestrator service.