While trying to attach a copy of the production database, SIM configuration process failed
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While trying to attach a copy of the production database, SIM configuration process failed

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Article ID: 248505

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Updated On:

Products

IT Management Suite Server Management Suite Client Management Suite

Issue/Introduction

The customer is performing a migration from ITMS 8.5 RU4 to 8.6 GA and then upgrading to 8.6 RU3. While trying to attach a copy of his production database to see if the migration process works, SIM failed almost at the end of the process saying:

Configuration failed
There were errors during installation. The following product(s) failed during installation (unless otherwise noted components of these products that were installed before the error were rolled back).
Symantec Management Platform 8.6 (8.6.1119)

SIM logs didn't show any specific error at the end of attaching the copy of the database that we could tell caused the issue.

After getting the SIM message above, we can click on "finish" and SIM doesn't show any partially configured Solutions/Components and the SMP Console loads just fine.

The only error noticed was at the beginning of attaching the copy of the database:

Install failure while installing (ProductComponent: (Package) Supportability 8.6 x64 8.6.1019 InstallOption: InstallRequired) (in product Symantec Management Platform 8.6). Windows Installer API return code: 110
-----------------------------------------------------------------------------------------------------
Date: 8/19/2022 12:32:58 PM, Tick Count: 346125 (00:05:46.1250000), Size: 504 B
Process: SymantecInstallationManager (6652), Thread ID: 16, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.PerformInstall.InstallProduct

Environment

ITMS 8.6 GA
SIM 8.6.4037 or earlier

Cause

Known issue. For our ITMS 8.6 GA release, we install an additional patch MSI for supportability - TelemetryPatch.msi (it is located in the SIM installation folder). In the customer's case, this MSI does not exist or can't be accessed (110 error means that the file is not accessible).


So what happens - SIM gets started for reconfiguration with another DB and first, it collects config files that must be re-configured. Technically our process looks like installation MSIs processing. As a part of this process, it ties to process this patch MSI just like any other ITMS MSI. It fails and sets a general failure flag. After that whole process gets completed without problems, DB gets switched, products re-configured, etc. Just on the last step SIM detects that there were failures and shows an Error page. After finishing attaching the pre-existing database, no functional issues are expected due to the error message (SMP shown as properly configured and SMP with local SMA works fine). 

 

Resolution

This issue has been reported to our Broadcom Development team. A fix for this has been added to our next SIM release (post 8.6.4037 version).

No functional issues are expected after finishing attaching the pre-existing database due to the error message (SMP Server should shown as properly configured and working fine). 

As workaround, you can just copy manually "TelemetryPatch.msi" to the Symantec Installation Manager\Installs\Altiris folder. SIM will try to load it from that path during re-configuration.