Ghost Solution Suite Automation Folder environmental issue related to system boot configuration
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Ghost Solution Suite Automation Folder environmental issue related to system boot configuration

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Article ID: 248269

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Updated On:

Products

Ghost Solution Suite

Issue/Introduction

Automation folder install on client machines is successful but endpoints will not boot to automation if instructed by a console job. Manually booting to the automation folder by selecting Symantec Deployment on start up is successful but unexpected errors may be seen Imaging with Ghost executables.

Cause

The issue described is not common and in at least one instance was caused by a corrupt boot/EFI partition. The endpoints were all imaged with the same image and strangely had no issue booting to Windows.

This very specific issue was verified by running bcdedit in an administrator command prompt on the endpoint. The very last line of output from "bcdedit" said the following:
"a device which does not exist was specified"
OR
"a device attached to the system is not functioning"

Resolution

The issue has been resolved by running diskpart in an administrator command prompt (while booted to Windows) and copying the boot data over to the volume Windows is installed on.

For assistance with diskpart, please refer to Microsoft documentation. Diskpart should not be used unless you are familiar with how it works. Commands entered incorrectly in diskpart can result in permanent data loss. Broadcom will not assist with running diskpart to fix environmental issues and this KB should be used at your own risk. Please refer to Microsoft documentation for further assistance with diskpart. The following bolded commands are an example. These were run without quotes and without the text in ( ).
"diskpart"
"list disk"
"select disk x"     (Replace "x" with the actual disk number listed with the previous command. This is usually disk 0)
"list volume"        (Verify if there is an EFI boot volume formatted (Fs) FAT32. This is usually around 100 MB, could be larger. Is there a letter in the "Ltr" column of that volume? If so, continue to the next command. If not, skip to the bcdboot command.)
"select volume x"  (Replace "x" with the volume number of the EFI boot volume from the previous command.)
"assign letter=s"    (Or another letter that isn't already in use)
"exit"
"c:\windows\system32\bcdboot c:\windows /s s: /f UEFI"     
(Replace c: with the volume letter where windows is installed and s: with the letter assigned to EFI/boot FAT32 partition if different)

Now run bcdedit and verify the error in the last line is gone