Missing PTFs when applying solutions via z/OSMF after CSM Receive
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Missing PTFs when applying solutions via z/OSMF after CSM Receive

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Article ID: 248236

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Updated On:

Products

Database Management for DB2 for z/OS - Administration Suite Database Management for DB2 for z/OS - Performance Suite Database Management for DB2 for z/OS - Recovery Suite Database Management for DB2 for z/OS - SQL Performance Suite Database Management for DB2 for z/OS - Utilities Suite DATABASE MANAGEMENT SOLUTIONS FOR DB2 FOR Z/OS

Issue/Introduction

Over one-hundred PTFs were received using CSM. Using z/OSMF Software Update to install Recommended PTFs only a small subset gets installed.

Cause

CSM had not received the CA RS and HIPER ++ASSIGN files into the product's Global zone for association with the selected PTFs being received.

Resolution

This condition was corrected by having CSM perform the Upgrade CA RS SMP/E process and specify 'Check Only'. 
This allowed the Global to be updated with the recommended SOURCEIDs for the PTFs in question, and a successful APPLY
for all the previously missing PTFs using z/OSMF to Apply recommended Service.

Additional Information

There are three types of Software Updates via z/OSMF.  The first type is Corrective updates where you specify specific PTFs / APAR names.
The second is Recommended updates based on Vendor supplied SOURCEIDs (CAR*, HIPER, RSL*,RSU*,SECINT, PRP). 
The third is Functional Updates based on Vendor supplied functional SOURCEIDs (example: CA-TargetSystem-RequiredService.product.version, etc.).