Virtual appliance response 'No filters could be matched'
search cancel

Virtual appliance response 'No filters could be matched'

book

Article ID: 248177

calendar_today

Updated On:

Products

Data Loss Prevention API Detection for Developer Apps Virtual Appliance

Issue/Introduction

The following response is returned by the DLP Detection Virtual Appliance.

{
    "messageId""filterNotFound",
    "message""No filters could be matched. Filter Id (11d5ab91-f6b6-462e-ab55-cca037a3fc56) not known."
}

Cause

You must have a key/pair value of 
common.filter with a value that matches the application ID found in Manage->Application Detection -> configuration -> application in question

Resolution

Ensure that 

{"name":"common.filter","value":["<ID found in the application configuration on Enforce"]},
 
is present in the body of the content sent to the appliance.