Clarity User Access Right Details Report fails, The report was not completed. An error occurred while executing it. error.generating.report
search cancel

Clarity User Access Right Details Report fails, The report was not completed. An error occurred while executing it. error.generating.report

book

Article ID: 248149

calendar_today

Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

In Clarity 16.0.2 the User Access Right Details Report fails when run in manual or scheduled modes.

Error Message:

Exception
Scheduled Job Info:
Label = Test User Access RIghts
ID = 172688956
Description = null
Status = FAIL

- The report was not completed. An error occurred while executing it.
error.generating.report
- com.jaspersoft.jasperserver.api.JSException: Error filling report
- Caused by: net.sf.jasperreports.engine.JRException: Error executing SQL statement for: CSK_USR_AccessRightsDetail.
- Caused by: org.postgresql.util.PSQLException: An I/O error occurred while sending to the backend.
- Caused by: java.net.SocketException: Socket closed

 

Environment

Release : 16.0.2

Component : Clarity Jaspersoft

Cause

The issue is being analysed as DE66571.

User Access Right Details report (CSK_USR_AccessRightsDetail) fails to load the data within the UI timeouts for SaaS environments with large volume of users.

STEPS TO REPRODUCE:

1. Login to Advanced reporting and open PMO Report:  User Access Right Details
2. Fill the basic input controls and run the report in either immediate or scheduled mode

Expected results: The report execution to return within 15 minutes of UI timeout
Actual results: The report fails and displays an Error message in the UI

Log error message: ERROR 2022-06-14 09:25:02,893 [http-nio-8080-exec-534] xql2.xbl (clarity:xxxxxxxxxx.com:41945126__AE8B4EDE-11AE-480A-A71C-406E9BF15B7F:nmc.executeAvailReport) RPT-0009: Report User Access Rights Detail did not complete in the stipulated time. Please try modifying the filter or schedule the report and view later from the Report Library. ::com.ca.ppm.reporting.exception.ReportingException: RPT-0009: Report User Access Rights Detail did not complete in the stipulated time. Please try modifying the filter or schedule the report and view later from the Report Library.
WARN  2022-06-14 09:25:02,912 [http-nio-8080-exec-534] niku.union (clarity:xxxxxxxxxx.com:41945126__AE8B4EDE-11AE-480A-A71C-406E9BF15B7F:nmc.executeAvailReport) RPT-0009: Report User Access Rights Detail did not complete in the stipulated time. Please try modifying the filter or schedule the report and view later from the Report Library. was not found in file: messages_en.properties

Resolution

The solution we want to deploy for this reports issue requires a Jaspersoft configuration change which will impact all Clarity customers.  Because we need to conduct end to end testing when we upgrade Jaspersoft, Engineering decided to implement this change in the next Program Increment (FY2023Q1) when we do the Jaspersoft upgrade.  It would be very risky to make this change now towards the end of a release.

Additional Information

Per Clarity Defect DE62193 the User Access Rights report issue was fixed in 16.0.2, reference https://knowledge.broadcom.com/external/article?articleId=235694