Duplicate entries in ODF_CARD table causes board view errors
search cancel

Duplicate entries in ODF_CARD table causes board view errors

book

Article ID: 248128

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Board view is not displaying tasks and there is a task that cannot be deleted (System error). There are picklist errors but even when deleting the picklist via REST API (via the UI it does nothing) and purging, the picklist is re-created and the error re-appears.

Steps to reproduce

  1. Open an affected project in Modern UX.
  2. Go to Task List.
  3. Choose board view.

Expected results: Board view is displaying tasks.

Actual Results: Board view is empty

A system error may be displayed ('API-1019 : Could not process the request due to internal error.'). app-ca.log may also show errors like:

ERROR xxxx-xx-xx xx:xx:xx,xxx [x] ppm.rest (clarity:x:x:PPM_REST_API) something happened converting lanes
com.niku.union.persistence.PersistenceException: 
SQL error code: 1
Error message: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-00001: unique constraint (x.ODF_ITEM_POSITIONS_PK) violated

Environment

Release : 16.0.2

Component : Clarity Studio

Cause

Duplicate entries in ODF_CARD table cause issues.

DE66042

Resolution

This issue has been fixed in Clarity 16.1.0.