Search returns strange results after database migration/move
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Search returns strange results after database migration/move

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Article ID: 248116

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

A 21.0 system was installed and started up.  Then a copy of a 12.x database was copied to the same database.  Once this was done, search results were very strange:

  • When an object was searched for in Client 0 and "Open" was chosen from the context menu, it would open the incorrect object
  • If an object was searched for in a different client and "Open" was chosen from the context menu, it would give a message the object wasn't found
  • If an object was searched for in a different client and "Show in Folder" was chosen from the context menu, an access denied message would show up.

Environment

Release : 21.0.1

Component :

Cause

By migrating/changing the JCPs and pointing them to what was then basically a different database, the lucene index that is used for searching was corrupted, having some information from the original database and some from the new database.  This cased the names and id numbers being different in the indexcache for the JCP.  

Resolution

The resolution for this was the following:

  1. Stop all WP and CP processes
  2. Delete all folders/files from the AutomationEngine/bin/indexCache folder
  3. Start all WP and CP processes
  4. Wait about 10 minutes

This allowed the lucene index to rebuild itself and then the search worked correctly.