WSS Agent Connecting to incorrect geolocation datacenter
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WSS Agent Connecting to incorrect geolocation datacenter

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Article ID: 248072

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Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

Issue has been encountered where users were trying to connect to WSS Services from India Office. However, the agent was connected to USA datacenter. This might create a few problems including higher latency. 

Environment

 WSS Agent

Cause

We need to understand the WSS Agent connection flow in order to know the cause behind it. Below is the flow the WSS Agent follows in order to determine the datacenter in which it needs to connect:

  • WSS Agent calls to Cloud Traffic Controller (CTC) over url: ctc.threatpulse.com when it starts or is reconnected.
  • CTC receives that connection and determines the IP from it was received. Usually it is the public egress IP of the institution/company.
  • CTC service uses Maxmind DB to get the geolocation of that egress IP and based on that data, it provides the nearest datacenter information to WSS Agent to connect.
  • Should that CTC connectivity be made from the egress IP which has the incorrect location in the database, CTC will instruct the agent to connect to the nearest WSS datacenter based on that egress IP geolocation. 

For an example, in the case where users were connecting from office in Bengaluru, India but their egress IP was defined as California, USA in Maxmind DB. CTC will be prompted to provide the nearest datacenters to that location which were in the USA.

Resolution

Maxmind DB needs to be fixed in order to resolve this issue. IP/Subnet owner can submit the request with Maxmind to correct the geolocation of their IP range. Once it gets fixed, CTC will start providing the correct WSS datacenter. 


Additional Information

Existing Maxmind link to raise correction request:

Submit GeoIP Data Corrections | MaxMind