Patch Management Import fails to run and finish
search cancel

Patch Management Import fails to run and finish

book

Article ID: 247954

calendar_today

Updated On:

Products

Client Management Suite Patch Management Solution

Issue/Introduction

PMImport does not run but stays in queued state. 

Environment

ITMS 8.6

Cause

In this case, there were many hung tasks and tasks configured to run every 10 minutes.

Resolution

Try the following:

  1. Delete all running instances of the Patch related tasks in Manage > Jobs/Tasks > Software > Patch Management.
  2. Remove daily schedule for "Check Software Update Package Integrity" (the recommendation is running this on demand while cleaning up previous updates).
  3. Clear the task instance tables per KB Article Taskinstances table grows rapidly.

    Note: In the case that PMImport task is not able to run, check and delete for unrelated tasks that may be scheduled to run every 10 minutes for example which can overload the Task Management system. Once you remove the schedule and pending or currently running instances of these tasks, the PMImport task immediately transitioned to a running state and finished successfully in time.