AppNeta - Monitoring Points unable to connect to AppNeta SaaS due to being deleted
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AppNeta - Monitoring Points unable to connect to AppNeta SaaS due to being deleted

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Article ID: 247951

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Updated On:

Products

AppNeta

Issue/Introduction

Monitoring Points that have been deleted from AppNeta SaaS will be actively blocked from connecting.

Cause

When a Monitoring Point is deleted from AppNeta SaaS we flag the Unique ID of the Monitoring Point and a list of deleted MPs which are actively blocked from connecting to AppNeta SaaS servers.

Resolution

In order to verify that the resolution steps are valid for the affected Monitoring Point you will first need to gather the current unique ID of the affected MP.  This can be gathered by inserting a blank FAT32 Formatted USB drive into the Monitoring Point for 2 minutes, after 2 minutes you will have several files on the drive one being a HTML file which contains a summary of the device's configuration.

In said HTML file we are after the Tunnel ID field, this is also referred to as it's unique ID or GUID:

 

 

Provide the Tunnel ID Value on a Support Case for further assistance if required.

 

In order to allow this Monitoring Point to connect to AppNeta SaaS servers again we will need to force the GUID to be regenerated.  This can be done through three different methods.

1. Factory Reset, this method will reset the entire monitoring point to factory default settings.  Instructions can be found in any MP models instruction set for Reset to Factory Defaults section: https://techdocs.broadcom.com/content/dam/broadcom/techdocs/us/en/dita/ca-enterprise-software/it-operations-management/appneta/pdfs/monitoring-point-m50.pdf
***NOTE*** This option will require that the monitoring point be fully reconfigured afterwards, recommended to have physical access to the device.

 

2. Decommission, this works similarly to the above but only causes the AppNeta Server specific settings to be reset/wiped including the GUID ID file.  You will need to re-apply the APM Connection Settings to the Monitoring Point once it has rebooted.  Instructions can be found in the same document link above under the Decommission section.

***NOTE*** This options requires access to the MP WebAdmin via it's Private IP Address.

 

3. Manually removing the .id file, this option requires SSH access to the monitoring point and should ideally be done over a screen share in order to actively observe or perform the actions taken.
We simply SSH into the Monitoring Point, delete the .id file and restart pathview-sequencer which forces the Monitoring Point to generate a new GUID ID.

sudo rm /opt/pathview/config/.id
sudo systemctl restart pathview-sequencer