java.lang.NoClassDefFoundError: com/workpoint/json/data/RequestDataTranslator
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java.lang.NoClassDefFoundError: com/workpoint/json/data/RequestDataTranslator

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Article ID: 247890

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Updated On:

Products

CA Identity Manager

Issue/Introduction

Customer is seeing the following exception each time the JBoss application server starts:

2022-07-21 13:31:25,606 INFO  [ims.Main] (ServerService Thread Pool -- 123) * Startup Step 4 : Attempting to start EnvironmentService

13:31:27,520 ERROR [stderr] (Query_jobq#JobQ1#WPDS) Exception in thread "Query_jobq#JobQ1#WPDS" java.lang.NoClassDefFoundError: com/workpoint/json/data/RequestDataTranslator

 13:31:27,520 ERROR [stderr] (Query_jobq#JobQ1#WPDS)             at com.workpoint.queue.query.JobQQueryThread.A(Unknown Source)

 13:31:27,520 ERROR [stderr] (Query_jobq#JobQ1#WPDS)             at com.workpoint.queue.query.JobQQueryThread.performQuery(Unknown Source)

 13:31:27,520 ERROR [stderr] (Query_jobq#JobQ1#WPDS)             at com.workpoint.queue.query.QQueryThread.run(Unknown Source)

 13:31:27,520 ERROR [stderr] (Query_jobq#JobQ1#WPDS) Caused by: java.lang.ClassNotFoundException: com.workpoint.json.data.RequestDataTranslator from [Module "deployment.iam_im.ear" from Service Module Loader]

 13:31:27,520 ERROR [stderr] (Query_jobq#JobQ1#WPDS)             at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:255)

 13:31:27,520 ERROR [stderr] (Query_jobq#JobQ1#WPDS)             at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:410)

 13:31:27,520 ERROR [stderr] (Query_jobq#JobQ1#WPDS)             at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)

 13:31:27,520 ERROR [stderr] (Query_jobq#JobQ1#WPDS)             at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:116)

 13:31:27,520 ERROR [stderr] (Query_jobq#JobQ1#WPDS)             ... 3 more

Environment

Release : 14.4

Component : IdentityMinder(Identity Manager)

Cause

If there are duplicate files/folders inside the iam_im.ear folder, then it would definitely cause issues as the JBoss server loads other folders. This issue also happens if the data in the WP_JOB_MONITOR table is corrupted.

Resolution

Resolution 1: Please remove the duplicate files/folders inside the deployed iam_im.ear folder, for example, in ../standalone/deployments/iam_im.ear.

Resolution 2: Additionally, check the WP_JOB_MONITOR table for duplicate entries for the same eventid. If you find multiple entries that correspond to multiple jobs for the same event, then delete the jobs using the designer. After removing the duplicates, restart the Application Server and the exception must disappear from the logs.

If removing the backup files/folders did not resolved the issue then,

Take a back up of WP_JOB_MONITOR table (it is not needed but just in case). After shutting down IM, use the following SQL command to clear the table:

Run the DELETE command on table WP_JOB_MONITOR WHERE PROC_REF IS NULL;

Which will clear nearly all the rows in the table. Start the IM and run the tests to make sure everything is working fine.

This may need to be redone.

Additional Information

We strongly recommend keeping your backup files/folders in a separate location, outside the working wildfly/jboss folder structure.

If you did not observe any of the duplicates as mentioned above but still see the same exception in the logs, clearing the WP_JOB_MONITOR table did not resolve the issue then please create a case for the support team to investigate further.