We can't stop Import of available vendors, software and languages: running.
search cancel

We can't stop Import of available vendors, software and languages: running.

book

Article ID: 247702

calendar_today

Updated On:

Products

Client Management Suite IT Management Suite Patch Management Solution

Issue/Introduction

In Metadata import task, the task Import of available vendors is running and we can't stop it.

We rebooted NS server, but the same status.

 

Environment

Release: 8.x

Cause

This is a rare occurrence. The Current and Last Statuses in the Windows Updates PreImport Worker State field was stuck as running, likely caused by an interruption in the background services and processes when the task was initially started.

Resolution

Caution: Make a backup of the Symantec CMDB database prior to running the below update query.

There are changes to prevent this situation in 8.6 RU3

To stop the task, first run this query and copy the State column contents to a text editor:

select name, cast(state as XML) as 'State' from item where guid = 'f8d384de-d891-4f1d-8a0f-7f9c92794a9f'

Look for these two tags:

<LastStatus>1</LastStatus><CurrentStatus>1</CurrentStatus>

Change the values for LastStatus and CurrentStatus to 3, and leave the rest of the result unchanged.

<LastStatus>3</LastStatus><CurrentStatus>3</CurrentStatus>

Copy the full edited result into this query and run the query:

update item set state = 'PASTE THE EDITED RESULT HERE BETWEEN THE SINGLE QUOTES' where guid = 'f8d384de-d891-4f1d-8a0f-7f9c92794a9f'