Z/OS Agent 21.0 is loosing connection to Event Monitor | U02005505 Event monitor ... lost connection to Agent
search cancel

Z/OS Agent 21.0 is loosing connection to Event Monitor | U02005505 Event monitor ... lost connection to Agent

book

Article ID: 247669

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

Z/OS Agent in version 21.0 and Event Monitor are unable to set up a stable connection. Both components are continuously rebuilding and loosing their connection link.

In the Agent log we see these massages every few minutes :

U02000043 No response from Agent 'ZOS_EM_E2' for '1' minutes and '3' seconds.
U02005505 Event monitor 'ZOS_EM_E2' lost connection to Agent 'ZOS_MP'.
U02002039 Successfully established connection with '<ip address 1>:30843' (socket handle = '9').
U02005504 Event monitor 'ZOS_EM_E2' connected to Agent 'ZOS_MP'.
This for all Event monitors connected

In the Event monitor log we see these messages :

recv error(rslt=0,errno=139,error=EDC5139I Operation not permitted.)
U02000013 Connection to Agent '<ip address 2>:2631' initiated.
U02000006 Connection to Agent 'ZOS_MP' was successfully established.
The AE is running in Azure and the connection from the agent to it is done via a TLS Gateway

In the provided TRC segment of the Agent data we can see it is looping with connecting and disconnecting

224BC80000000000 20220329/063852.596 - 20220329/063852.595 - U02005505 Event monitor 'ZOS_EM_E1' lost connection to Agent '
20220329/063852.659 - U02005504 Event monitor 'ZOS_EM_E1' connected to Agent 'ZOS_MP'.
224EA80000000001 20220329/063852.659 - 20220329/063852.659 - U02005504 Event monitor 'ZOS_EM_E1' connected to Agent 'ZOS_AZ
20220329/063902.660 - U02005505 Event monitor 'ZOS_EM_M1' lost connection to Agent 'ZOS_MP'.
224BC80000000000 20220329/063902.660 - 20220329/063902.660 - U02005505 Event monitor 'ZOS_EM_M1' lost connection to Agent '
20220329/063902.660 - U02005505 Event monitor 'ZOS_EM_M2' lost connection to Agent 'ZOS_MP'.
224BC80000000000 20220329/063902.660 - 20220329/063902.660 - U02005505 Event monitor 'ZOS_EM_M2' lost connection to Agent '
20220329/063902.661 - U02005505 Event monitor 'ZOS_EM_E2' lost connection to Agent 'ZOS_MP'.
224BC80000000000 20220329/063902.661 - 20220329/063902.661 - U02005505 Event monitor 'ZOS_EM_E2' lost connection to Agent '
20220329/063902.719 - U02005504 Event monitor 'ZOS_EM_M1' connected to Agent 'ZOS_MP'.

Environment

Release : 21.0.1 Component : AUTOMATION ENGINE 

Z/OS system version : Hardware = '3906-735'. Software = 'OS/390'. SW version = '7.2.4'.

Cause

This is a bug introduced in the Z/OS agent 21.0

Resolution

Solution:

Update to a fix version listed below or a newer version if available.

Fix version:
Component(s): Agent MVS
Automation.Engine 21.0.4 - Available

 

Additional Information

Solution Details: A problem has been solved where the z/OS Event Monitor periodically lost connection to the Agent when the AE system websocket timeout was set to 60 seconds.