After upgrading the TDM Porta when trying to access the portal from browser we get a 404 erro
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After upgrading the TDM Porta when trying to access the portal from browser we get a 404 erro

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Article ID: 247645

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

There are errors in some logs. I still cannot access CA TDM Portal from Edge (received http 404 error).  
Is it possible that port 8443 changed during the upgrade?  

Error from the logs

FINEST|2308/0|22-08-04 17:55:51|SEVERE: Error deploying web application archive [X:\Program Files\CA\CA Test Data Manager Portal\tomcat\webapps\TestDataManager.war]
FINEST|2308/0|22-08-04 17:55:51|java.lang.IllegalStateException: Error starting child

FINEST|2308/0|22-08-04 17:55:51|Caused by: org.apache.catalina.LifecycleException: Failed to initialize component [org.apache.catalina.webresources.JarResourceSet@7439b828]

FINEST|2308/0|22-08-04 17:55:51|Caused by: java.lang.IllegalArgumentException: java.util.zip.ZipException:zip file is empty
FINEST|2308/0|22-08-04 17:55:51| at org.apache.catalina.webresources.AbstractSingleArchiveResourceSet.initInternal(AbstractSingleArchiveResourceSet.java:143)
FINEST|2308/0|22-08-04 17:55:51| at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:136)
FINEST|2308/0|22-08-04 17:55:51| ... 19 more
FINEST|2308/0|22-08-04 17:55:51|Caused by: java.util.zip.ZipException: zip file is empty

Environment

TDM Web Portal
Test Data Manager

Cause

There was a corrupt WAR file on the system

Resolution

Steps to resolve the issue
1) stop the TDM Portal service.
2) make a backup of the TDM Portal directory
3) empty the *.war files from the <CA Test Data Manager Portal>\tomcat\webapps directory.
4) Disable any antivirus
5) run the latest version installer.

Test-Data-Manager-TDM-Patches
https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/release-announcements/Test-Data-Manager-TDM-Patches/16649