Issue in connecting to the ROC errors out Gateway Time-out
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Issue in connecting to the ROC errors out Gateway Time-out

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Article ID: 247552

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio)

Issue/Introduction

We've installed a new instance of the NAC and the website comes up, but when we select the ROC we get a 

504 Gateway Time-out

    When we trying directly from the NAC server using localhost it just keeps looping does not even time out.

    Not currently seeing any errors in the logs

Environment

Release : 6.x

Component : CA RELEASE AUTOMATION DATA MANAGEMENT SERVER

Cause

One of the two NAC in HA (High Availability) setup connected to the same DB was upgraded to version 6.7.0.81 resulting in DB schema get upgraded. The other instance of NAC is still on old version i.e. 6.6.0.9640 which was unaware about schema updates related to 6.7.0.81 and hence fails to be master NAC, resulting in above error.

Resolution

  1. Upgrade NAC of PROD to version available in the table version_table (select * from version_table)
  2. Stop the NAC service on DEV server
  3. Restart the NAC service on PROD server give some time to be MASTER
  4. Try login again