ROC Login Page doesn't render
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ROC Login Page doesn't render

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Article ID: 247534

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Updated On:

Products

CA Release Automation - DataManagement Server (Nolio) CA Release Automation - Release Operations Center (Nolio)

Issue/Introduction

We are facing an issue where when we try to navigate to ROC Login page it just doesn't render and keep processing. We checked the Logs but doesn't find any relevant error.

Can you explain the cause?

Environment

Release : 6.x

Component : CA RELEASE AUTOMATION

OS: Windows Server 2019

Cause

During investigation it was observed that in active_mq_nac.log we see error around DNS resolution where a specific hostname is not resolved to IPv4.

Validation to be performed on NAC server

  • ping NAC_HOSTNAME 
# resolving to  IPv6 instead of IPv4
  • ping NES_HOSTNAME
# resolving to IPv6 instead of IPv4

For all servers i.e. Agents, NES, NAC a corresponding entry is made by NAC in the exec_servers, servers, nac_nodes table where it maps hostname to IPv4. The product requires static IPv4 address to work and establish connection. 

In the environment all the components i.e. NAC, NES's are resolving to IPv6 instead of IPv4 address resulting in the error.

Resolution

There are two ways to resolve issue

Solution 1: (OS agnostic)

Solution 2: (Windows specific)

  • On each server a registry change can be made to make IPv4 as default resolution.
reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters" /v DisabledComponents /t REG_DWORD /d 0xFF /f