Symantec Identity Manager - incorrect server.log is being updated
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Symantec Identity Manager - incorrect server.log is being updated

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Article ID: 247433

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Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

Identity Manager is randomly updating older variants of the server.log

Environment

Release : 14.4.1CHF2

Component : IdentityMinder(Identity Manager)

Cause

The log4j_jboss.xml is missing the TimeBasedTriggeringPolicy declaration.

Resolution

The issue was due to an incomplete configuration of the wildfly-idm/standalone/deployments/iam_im.ear/config/com/netegrity/config/log4j_jboss.xml.

Update the file to the below value and then restart the application server.

<RollingFile fileName="${LogFileDir}/server.log" filePattern="${LogFileDir}/server.log.%d{yyyy-MM-dd}-%i" name="rollingLogger"> 
<PatternLayout>
<pattern>%d{yyyy-MM-dd HH:mm:ss,SSS} %-5p [%c] (%t) %m%ex%n</pattern>
<charset>UTF-8</charset>
</PatternLayout>
<Policies>
<TimeBasedTriggeringPolicy interval="1" modulate="true"/>
<SizeBasedTriggeringPolicy size="100MB" />
</Policies>
</RollingFile>

Additional Information

Apply 14.4 CP2 when it is available.