Agent or Server Upgrade to CU3 or CU4 fails with Exit code 60 indicates possible error [SDM228001]
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Agent or Server Upgrade to CU3 or CU4 fails with Exit code 60 indicates possible error [SDM228001]

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Article ID: 247379

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

Agent or Server Upgrade to CU3 or CU4 using the provided SD Package fails with Exit code 60 indicates possible error [SDM228001]
 
Example of SD Packages :
 
CA DSM Agent + Explorer +  Scalability Server 14.5 CU3 (Win32 only) 14.5.0.369
CA DSM Agent + Explorer +  Scalability Server 14.5 CU4 (Win32 only) 14.5.0.430
 
 
In SD Job Output there are these errors :
Executing PRESYSCMD command = preInstall_enc.bat
preInstall_enc.bat - Error executing system command. Continuing...
Executing SYSCMD command = postInstall_enc.bat
postInstall_enc.bat - Error executing system command. Continuing...

 

This problem occurs when SD Agent is using NOS connection method for SD Library.
With NOSLess mode it is working.

Environment

Client Automation 14.5

Cause

Exit code 60 for applyptf.exe indicates a problem with execution of command in PRESYSCMD or SYSCMD section of .jcl file.
 
In 99111479.jcl (CU3) and 99111509.jcl (CU4) there are these lines :

PRESYSCMD:preInstall_enc.bat
SYSCMD:postInstall_enc.bat
 
In NOS mode SD Agent could not find the file preInstall_enc.bat and postInstall_enc.bat and applyptf.exe returns the exit code 60

Resolution

Solution 1 :

Configure the SD Agent to NOS Less download method

 

Solution 2 :

Update the file 99111479.jcl (CU3) and 99111509.jcl (CU4) like this :


PRESYSCMD:.\preInstall_enc.bat
SYSCMD:.\postInstall_enc.bat

 

and import the SD package with updated jcl files.