Service Desk Manager error: AHD03055:Data partition  restriction on Knowledge Document
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Service Desk Manager error: AHD03055:Data partition  restriction on Knowledge Document

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Article ID: 247374

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

The following entries appear in stdlog:

kt_daemon               4756 SIGNIFICANT  HitKD.c                924 Unable to update LAST_HIT_DATE for Knowledge Document id: 40XXXX. AHD03055:Data partition  restriction on Knowledge Document"

 

Environment

Release : 17.3.x

Component : SDM - Configuration

Cause

OOTB Data partition Pre-update restriction on Skeletons table causes this issue to occur. 

Type = Pre-Update | Table = Skeletons | Contraint: id = 0

Resolution

When a user (employee or analyst) clicks on a KB article, it will trigger an action to update the skeleton table and update the last_hit_column to save the date the last hit date. With the DP restriction, the employee can't update this column causing the issue to occur. If you inactive the restriction in the DP, the update will occur and the error message won't appear in the stdlogs.

We don't see any problem inactivating this rule in the employee DP since it won't cause any impact, besides updating the last_hit_column when the employee clicks on the KB article.

1. Log into SDM as an Administrator > Security and Role Management

2. Data Partitions > Data Partition List > Employee 

3. Search for Type = Pre-Update | Table = Skeletons | Contraint: id = 0 > Click on the constraint

4. Edit > Set to Inactive