How to update the Non Resident Inventory(NRI) signature database when NRI couldn't detect some new applications during advanced scan.
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How to update the Non Resident Inventory(NRI) signature database when NRI couldn't detect some new applications during advanced scan.

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Article ID: 24731

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

NRI couldn't detect some new applications during advanced scan.

Is the NRI database updated automatically when the software content download is run?

Environment

CA Client Automation - All Versions

Cause

CA Client Automation automatically downloads CA Provided signatures to the manager for use with the CA agents.

However, the Non Resident Inventory solution is not included in these automatic updates, so you have to perform these updates manually.

Resolution

To manually update the signature database used by the Advanced Scan package:

  1. Open a file explorer on the server hosting the solution.

  2. Navigate to the ...DSM\ServerDB\SECTOR\SSFW folder.
    The folder contains a list of W0000xxx.zml files.

  3. Locate the .ZML file with the highest number, for example, W0000084.zml.

  4. Copy the file to Web Console\webapps\wac\jsp\ei\wl\windows\packages.

  5. Navigate to Web Console\webapps\wac\jsp\ei\wl\windows\packages.

  6. Remove file named w0000001.zml.

  7. Rename the copied file to w0000001.zml.

Additional Information

For more information on using NRI please review the CA Client Automation Implementation Guide at this link:

Non Resident Inventory