New Portal install fails to successfully install MySql
search cancel

New Portal install fails to successfully install MySql

book

Article ID: 247309

calendar_today

Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

Installing PC Portal 21.2.11 but seeing the following errors. All other PC services are installed without error. Only MySql shows errors.

The MySql errors are these from the MySql_Install_<Date>_<Time>.log file. It shows two FatalError entries.

Summary
-------
Installation: Unsuccessful.
417 Successes
0 Warnings
0 NonFatalErrors
2 FatalErrors

The first error is:

Execute Script/Batch file:   Initializing...
                          Status: SUCCESSFUL
Custom Action:            com.ca.im.installanywhere.action.GenerateInstallFailure
                          Status: FATAL ERROR
                          Additional Notes: FATAL ERROR -     class com.ca.im.installanywhere.action.GenerateInstallFailure FatalInstallException: MySql DB initialization failed!
Checking /etc/profile to see if any PATH= line contains :/opt/CA/MySql/bin"
Looking up version property in file: /etc/my.cnf
Looking up version property in file: /tmp/017285.tmp/MySql/my.cnf
Current MySQL configuration version is latest - no install needed.

Then a short bit further down in the log:

Execute Script/Batch file:   Install UDF as script
                          Status: SUCCESSFUL
Custom Action:            com.ca.im.installanywhere.action.GenerateInstallFailure
                          Status: FATAL ERROR
                          Additional Notes: FATAL ERROR -     class com.ca.im.installanywhere.action.GenerateInstallFailure FatalInstallException: Error loading UDF plugin.  v6_* functions will be unavailable for GlobalSync, etc!!!
Execute Script/Batch file:   Restart MySql
                          Status: SUCCESSFUL

Environment

All supported DX NetOps Performance Management releases

Cause

The umask value is set incorrectly for the root user. The system had the root user umask set to 0027. We require 022. This setting was propagated to the mysql user as well.

This prevented the mysql user from accessing the /opt/CA/MySql directory and any other directories or files within it. Without that ability the install would fail.

Resolution

To resolve this take the following steps. This assumes a new install so no need to back anything up.

  1. Ensure it's cleaned up from the prior install as per the instructions under:

    TechDocs : DX NetOps 24.3 : Uninstall NetOps Portal

  2. Set umask for the root and mysql users to 022:
    1. Log in as the root user. Run:
      • umask 022

    2. Log in as the mysql user using the "su -" then set umask to 022 with these two commands.
      • su - mysql
      • umask 022

  3. Run the Portal Install again as if new with the correct configuration now in place.

Additional Information

In some situations the umask may be reset due to internal requirements. In these cases set the umask in the .profile for each affected user.