Management Center Web GUI is not loading and displays blank page
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Management Center Web GUI is not loading and displays blank page

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Article ID: 247260

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Updated On:

Products

Management Center

Issue/Introduction

Management Center Web GUI is not loading and displays blank page

Environment

Release: 3.2.1.1

Cause

  • connectivity issue to web server
  • management service is down
  • services are corrupted from the downgrade of SW

Resolution

If CLI is available. Please follow troubleshooting steps:

 

- CHECK FOR THE BACKUP

> enable

MgmtCtr# backup view

MgmtCtr# backup create

MgmtCtr# backup export <index#> scheme://ip/path passphrase <your_desired_passphrase> username <file_server_username>  password <<hit enter to be prompted to enter your server password>>

Management Center# backup export 1 scp://10.16.101.182/home/leo/mc passphrase pineapple1 username leo password

Could be SCP or FTP

KB: https://knowledge.broadcom.com/external/article?articleId=169235

 

- CHECK MANAGEMENT CENTER VERSION INSTALLED

MgmtCtr> show version

 

- CHECK THE INTERNET ACCESS TO MGMT CENTER

Make sure that the Management Center has access to the Internet and *.bluecoat.com domain. On Proxy make sure that the connection to *.bluecoat.com is not being SSL intercepted.

MgmtCtr> enable

MgmtCtr# ping 8.8.8.8

MgmtCtr# ping bto-services.es.bluecoat.com

MgmtCtr# ping validation.es.bluecoat.com

 

- CHECK FIREWALL FOR PORT 8082 (HTTPS)

Make sure that the port 8082 is not blocked by the firewall to access the Management Center GUI

 

- CHECK LICENSE

> enable

MgmtCtr# config

MgmtCtr (config)# licensing

MgmtCtr (config-licensing)# view status

(config-licensing)# view

KB:https://techdocs.broadcom.com/us/en/symantec-security-software/web-and-network-security/management-center/3-3/index/c_config_commands/c_licensing.html

 

- CHECK BIRTH CERTIFICATE ON APPLIANCE

MgmtCtr> enable

MgmtCtr# config

MgmtCtr(config)# ssl

MgmtCtr(config-ssl)# view keyring bluecoat-appliance

MgmtCtr(config-ssl)# trust-package view

MgmtCtr(config-ssl)# view ca-certificate ABRCA_root

 

- RELOAD LICENSE

MgmtCtr # config

MgmtCtr (config)# licensing load username [email protected] password helloworld

 

- MANUALLY RESTART SERVICE VIA CLI

MgmtCtr> enable

MgmtCtr# system-services status management-center

'management-center' is stopped

MgmtCtr# system-services stop management-center

'management-center' was stopped

MgmtCtr# system-services start management-center

'management-center' was started successfully.

MgmtCtr# system-services status management-center

'management-center' was started successfully.

 

- MAKE HARD REBOOT OF THE MGMT Center

 Reboot the MGMT Center appliance

MgmtCtr> enable

Password:

MgmtCtr# restart

 

- CHECK IF ACL IS NOT BLOCKING ANY SUBNET FROM REACHING THE WEB GUI

MgmtCtr# config

MgmtCtr(config)# show full-configuration acl

MgmtCtr(config)# acl disable

Try to reach the webpage https://<MGMT-CENTER>:8082

 

- CHECK IF THE HTTP VERSION IS LOADING ON PORT 8080

MgmtCtr# security http enable

Check the HTTP version http://<MGMT-CENTER>:8080

 

- SSL CERTIFICATES CHECK

MgmtCtr# ssl view certificate default

MgmtCtr# ssl view certificate bluecoat-appliance

If the CLI reports that the self-signed certificates are not present, you'll need to create them. 

KB: https://knowledge.broadcom.com/external/article?articleId=173196

 

 

IF ALL THE ABOVE STEPS FAILS, PLEASE SEND THE DIAGNOSTICS TO TICKET TO TRY DETERMINE THE ROOT CAUSE

If all the steps fails, we can check what could be a problem by getting the diagnostics file from the MGMT Center

MgmtCtr# diagnostics heartbeat send

MgmtCtr# diagnostics service-info send <TICKET NUMBER>

or to scp server as sample:

MgmtCtr# diagnostics service-info send url scp://mytransferhost.example.com/files username bob pass

 

 

###### POSSIBLE SOLUTIONS ######

- REVERT THE MGMT Center TO FACTORY DEFAULTS AND RESTORE THE CONFIG WITH BACKUP

KB: https://techdocs.broadcom.com/us/en/symantec-security-software/web-and-network-security/management-center/3-2/manage_jobs/add_job/factory_restore_job.html

- UPGRADE THE MGMT CENTER VIA CLI

Upload the install package bcsi of management center to some web server which does not have https

example: http://webserver.mycompany.com/images/542386.bcsi

> enable

MgmtCtr# security http enable

MgmtCtr# installed-systems load http://webserver.mycompany.com/images/542386.bcsi

 

After successful upgrade 

#restart

KB: https://knowledge.broadcom.com/external/article?articleId=176375

 

After the upgrade check:

HTTPS: https://<MGMT-CENTER>:8082

HTTP: http://<MGMT-CENTER>:8080

Additional Information

Check the diagnostics sosreport from MGMT Center for any failures:

  • sosreport-XXX\sos_commands\systemd\systemctl_status_--all
  • sosreport-XXXX\var\log\messages

Check for recent upgrades/downgrades:

  • sosreport-XXXX\var\log\clp_alerts.log

 

Option that most of time resolves the issue, would be to make factory default and restore from backup.