Confused Root cause analysis causes event storm in Spectrum
search cancel

Confused Root cause analysis causes event storm in Spectrum

book

Article ID: 247258

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

We noticed that when we create 2 fanout connections by Model By Type without any IP Address and then we make a connection between these two fanout models, Spectrum will immediately become unresponsive and we can see an Event Storm be created between these two fanout models.

If we do not destroy one of these fanout models via CLI, then the Event Storm will eventually crash Archive Manager and cause the SpectroSERVER to shut itself down.

Environment

Release : 21.2.x

Component : Spectrum Core / SpectroSERVER

Cause

No protection in the code to prevent invalid root cause scenarios such as this

Resolution

This will be addressed as part of User Story US834670 in a future Spectrum release.