Report scheduler is not working
search cancel

Report scheduler is not working

book

Article ID: 247214

calendar_today

Updated On:

Products

Information Centric Analytics

Issue/Introduction

Scheduled exports fail to run. The error logged in the table RiskFabric.ScheduledExport_TasksHistory is 'Unauthorized'.

The portal setting 132 (DashboardEnableScheduledExport) = 1 and the value for portal setting 392 (WebsiteURL) is correct and accessible. Portal SMTP settings are correct and functional and e-mail notifications are being sent and delivered regularly to a number of users, including the user in question. Only scheduled dashboard exports fail to be delivered. No information related to failed scheduled exports is being logged in the EmailActivityLog and ActivityLog tables.

The portal user who scheduled the report is a portal administrator and has been assigned portal permissions 73, 74, and 75 (CanExportGeneral, CanExportDashboard, CanExportScheduler). These permissions are inherited by this user through a portal role and are also assigned directly to the portal user account. All reports scheduled by other users fail to run. The RiskFabricAppPool identity account is a local administrator on the application (IIS) server with both read and write access to the path %Temp%. It also has been granted full rights to the path %SystemDrive%\Program Files\Bay Dynamics\Risk Fabric Server Web\ and its contents.

Login to the Information Centric Analytics (ICA) portal as the RiskFabricAppPool identity fails if attempted directly on the application (IIS) server. Login from any other system succeeds.

Environment

Release : 6.x

Component : Microsoft Internet Information Services

Cause

A Group Policy Object (GPO) is preventing the RiskFabricAppPool identity account from accessing the site from the application (IIS) server.

Resolution

Modify or disable the GPO preventing the RiskFabricAppPool identity account from accessing the site from the application (IIS) server.